# Error "Not Authenticated"

**URL:** <https://talk.openelis-global.org/t/error-not-authenticated/241>\
**Category:** Ask OpenELIS\
**Created:** [January 12, 2024, 11:36am UTC](https://talk.openelis-global.org/t/error-not-authenticated/241 "2024-01-12T11:36:07Z")\
**Posts on this page:** 20\
**Page:** 1

<div class="post-metadata">

**Author:** ![Agaba\_Derrick\_Junior](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/agaba_derrick_junior/32/503_2.png) [@Agaba\_Derrick\_Junior](https://talk.openelis-global.org/u/Agaba_Derrick_Junior)\
**Post date:** [January 12, 2024, 11:36am UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/1 "2024-01-12T11:36:07Z")

</div>

![Screenshot from 2024-01-12 06-28-47](https://canada1.discourse-cdn.com/flex030/uploads/openelisci/original/1X/a5ffdee525e4c2b4d9af16484b03ce8b5531e179.png)  
Hey everyone, I’ve been experiencing an issue after fetching the latest changes on branch 2.8. Every time I fire up the server, I encounter a white screen with a message saying ‘not authenticated.’ Has anyone else encountered this problem, and if so, could you share any insights or solutions you’ve found?  
@tendomart  
@Moses_Mutesasira

---

<div class="post-metadata">

**Author:** ![tendomart](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/tendomart/32/94_2.png) [@tendomart](https://talk.openelis-global.org/u/tendomart)\
**Post date:** [January 12, 2024, 12:57pm UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/2 "2024-01-12T12:57:15Z")

</div>

I experienced this too some time back.

you proably need to clean your browser cache, docker cache and drop some dangling images.

@Moses_Mutesasira some thing needs to be done

---

<div class="post-metadata">

**Author:** ![tendomart](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/tendomart/32/94_2.png) [@tendomart](https://talk.openelis-global.org/u/tendomart)\
**Post date:** [January 12, 2024, 1:02pm UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/3 "2024-01-12T13:02:18Z")

</div>

It may not be a priority, but i think we need to have a OpenELIS SDK to ease the process, setup on smaller footprint especially the frontend. Since we already have fhir endpoints, the UI can always use them separately.

---

<div class="post-metadata">

**Author:** ![Moses\_Mutesasira](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/moses_mutesasira/32/72_2.png) [@Moses\_Mutesasira](https://talk.openelis-global.org/u/Moses_Mutesasira)\
**Post date:** [January 15, 2024, 10:23am UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/4 "2024-01-15T10:23:55Z")

</div>

can you try  
Pulling the latest image changes and spin up again ??

- Pull the latest Image changes  
`docker-compose -f dev.docker-compose.yml pull oe.openelis.org frontend.openelis.org`

- Remove the containers  
`docker-compose -f dev.docker-compose.yml down`

- Start them again  
`docker-compose -f dev.docker-compose.yml up -d`

---

<div class="post-metadata">

**Author:** ![aditya](https://avatars.discourse-cdn.com/v4/letter/a/df705f/32.png) [@aditya](https://talk.openelis-global.org/u/aditya)\
**Post date:** [January 22, 2024, 7:51pm UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/5 "2024-01-22T19:51:02Z")

</div>

![image](https://canada1.discourse-cdn.com/flex030/uploads/openelisci/original/1X/39cd39786ee128e86a23403c4061a1c2102d11a9.png)

Hey

context : [I have dev.docker-compose.yml running in the background also i don’t have build errors]

I have pulled latest images still having error [Not Authenticated]  
also  
I think there is no container which is handling request at localhost:3000/api/open…

still in trouble !

EDIT : **problem solved : )**

---

<div class="post-metadata">

**Author:** ![Agaba\_Derrick\_Junior](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/agaba_derrick_junior/32/503_2.png) [@Agaba\_Derrick\_Junior](https://talk.openelis-global.org/u/Agaba_Derrick_Junior)\
**Post date:** [January 23, 2024, 12:19pm UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/6 "2024-01-23T12:19:20Z")

</div>

@aditya kindly share steps of how you have solved this

---

<div class="post-metadata">

**Author:** ![aditya](https://avatars.discourse-cdn.com/v4/letter/a/df705f/32.png) [@aditya](https://talk.openelis-global.org/u/aditya)\
**Post date:** [January 23, 2024, 5:27pm UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/7 "2024-01-23T17:27:16Z")

</div>

@Agaba_Derrick_Junior

when running `npm run start` on the frontend folder it sends you to `https://localhost:3000` because of proxy already setuped on that port it doesn’t send api call/request to backend. To fix the problem just remove :3000 from the URL and write there `/login`.

the final url `https:/localhost/login`

That solved this issue/problem !

---

<div class="post-metadata">

**Author:** ![Moses\_Mutesasira](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/moses_mutesasira/32/72_2.png) [@Moses\_Mutesasira](https://talk.openelis-global.org/u/Moses_Mutesasira)\
**Post date:** [January 24, 2024, 8:07am UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/8 "2024-01-24T08:07:59Z")

</div>

We are running both the frontend and backend behind a proxy .  
Just access the app on `https:/localhost`

---

<div class="post-metadata">

**Author:** ![Moses\_Mutesasira](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/moses_mutesasira/32/72_2.png) [@Moses\_Mutesasira](https://talk.openelis-global.org/u/Moses_Mutesasira)\
**Post date:** [January 25, 2024, 8:59pm UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/9 "2024-01-25T20:59:39Z")

</div>

Hello @Agaba_Derrick_Junior ,  
Is there any progress on fixing your error from the dev call??

---

<div class="post-metadata">

**Author:** ![Agaba\_Derrick\_Junior](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/agaba_derrick_junior/32/503_2.png) [@Agaba\_Derrick\_Junior](https://talk.openelis-global.org/u/Agaba_Derrick_Junior)\
**Post date:** [February 1, 2024, 11:29am UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/10 "2024-02-01T11:29:19Z")

</div>

hey @Moses_Mutesasira sorry for the late replies, I am quite sick and am in the hospital,  
I managed to fire up the server after the dev call but after a day or 2 of pulling the latest images, it’s now that I’m facing the same problem again

---

<div class="post-metadata">

**Author:** ![Moses\_Mutesasira](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/moses_mutesasira/32/72_2.png) [@Moses\_Mutesasira](https://talk.openelis-global.org/u/Moses_Mutesasira)\
**Post date:** [February 1, 2024, 4:54pm UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/11 "2024-02-01T16:54:26Z")

</div>

> [@Agaba\_Derrick\_Junior](#):
>
> I am quite sick and am in the hospital,

Sorry about that.  
Quick recovery

---

<div class="post-metadata">

**Author:** ![aditya](https://avatars.discourse-cdn.com/v4/letter/a/df705f/32.png) [@aditya](https://talk.openelis-global.org/u/aditya)\
**Post date:** [February 2, 2024, 8:25pm UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/12 "2024-02-02T20:25:12Z")

</div>

[![](https://canada1.discourse-cdn.com/flex030/uploads/openelisci/original/1X/39cd39786ee128e86a23403c4061a1c2102d11a9.png) ](https://canada1.discourse-cdn.com/flex030/uploads/openelisci/original/1X/39cd39786ee128e86a23403c4061a1c2102d11a9.png)

hey @Moses_Mutesasira @caseyi

while running frontend from the src/frontend/ via command `npm run start` !  
i got the above image error i think that is causing because non of the containers is handling that route [[https://localhost:3000/api/OpenELIS-Global/ValidateLogin?apiCall=true](https://localhost:3000/api/OpenELIS-Global/ValidateLogin?apiCall=true) ]

i have that error i want to run the backend using containers and frontend from local command. Also and don’t want to start frontend from containers mean while it should be constant connection .

Please help 😢

Thank You

---

<div class="post-metadata">

**Author:** ![aditya](https://avatars.discourse-cdn.com/v4/letter/a/df705f/32.png) [@aditya](https://talk.openelis-global.org/u/aditya)\
**Post date:** [February 4, 2024, 7:16pm UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/13 "2024-02-04T19:16:31Z")

</div>

@Moses_Mutesasira sorry for tag !  
please help me with above issue and tell the steps required to perform !

---

<div class="post-metadata">

**Author:** ![Moses\_Mutesasira](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/moses_mutesasira/32/72_2.png) [@Moses\_Mutesasira](https://talk.openelis-global.org/u/Moses_Mutesasira)\
**Post date:** [February 5, 2024, 10:54am UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/14 "2024-02-05T10:54:12Z")

</div>

> [@aditya](#):
>
> [https://localhost:3000/api/OpenELIS-Global/ValidateLogin?apiCall=true](https://localhost:3000/api/OpenELIS-Global/ValidateLogin?apiCall=true) ]

Both the front end and backend are running behind the nginix poxy.  
so the actual URL is ` https://localhost`

> [@aditya](#):
>
> Also and don’t want to start frontend from containers mean while it should be constant connection .

Is there a technical reason you don’t want to run it in the containers ?? ideally, it still hot reloads from the container.

But if you want to run the frontend on your machine , then you’ll have to adjust the [nginx configuration](https://github.com/I-TECH-UW/OpenELIS-Global-2/blob/develop_3x/volume/nginx/nginx.conf#L26-L43) appropriately depending on your OS

---

<div class="post-metadata">

**Author:** ![Agaba\_Derrick\_Junior](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/agaba_derrick_junior/32/503_2.png) [@Agaba\_Derrick\_Junior](https://talk.openelis-global.org/u/Agaba_Derrick_Junior)\
**Post date:** [May 9, 2024, 7:59am UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/15 "2024-05-09T07:59:38Z")

</div>

hello community,  
am facing this problem which is again bringing a not Authenticated error,

> **[liquibase error - Pastebin.com](https://pastebin.com/F49PULDX)**
>
> Pastebin.com is the number one paste tool since 2002. Pastebin is a website where you can store text online for a set period of time.

@mozzymutesa

---

<div class="post-metadata">

**Author:** ![Manish](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/manish/32/472_2.png) [@Manish](https://talk.openelis-global.org/u/Manish)\
**Post date:** [May 9, 2024, 11:36am UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/16 "2024-05-09T11:36:30Z")

</div>

Hey @Agaba_Derrick_Junior try killing and recreating the containers!

---

<div class="post-metadata">

**Author:** ![aditya](https://avatars.discourse-cdn.com/v4/letter/a/df705f/32.png) [@aditya](https://talk.openelis-global.org/u/aditya)\
**Post date:** [May 9, 2024, 12:16pm UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/17 "2024-05-09T12:16:23Z")

</div>

```auto
 docker-compose -f dev.docker-compose.yml down -v

```

Then

```auto
 cd OpenELIS-Global-2
 git submodule update --init --recursive
 cd dataexport
 mvn clean install -DskipTests

```

after this

```auto
 docker-compose -f dev.docker-compose.yml up -d    

```

if this doesn’t fix perform 1 & 2 nd step again and this time

run

```auto
docker-compose -f dev.docker-compose.yml up -d --no-deps --force-recreate oe.openelis.org          

```

and then run

```auto
 docker-compose -f dev.docker-compose.yml up -d    

```

---

<div class="post-metadata">

**Author:** ![Agaba\_Derrick\_Junior](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/agaba_derrick_junior/32/503_2.png) [@Agaba\_Derrick\_Junior](https://talk.openelis-global.org/u/Agaba_Derrick_Junior)\
**Post date:** [May 9, 2024, 3:42pm UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/18 "2024-05-09T15:42:52Z")

</div>

surely this worked ! thanks @aditya @Manish

---

<div class="post-metadata">

**Author:** ![tasksolver](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/tasksolver/32/1067_2.png) [@tasksolver](https://talk.openelis-global.org/u/tasksolver)\
**Post date:** [November 6, 2024, 1:56pm UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/19 "2024-11-06T13:56:19Z")

</div>

it really worked out, thanks, does it mean that for better working environment, I have to restart the docker containers cause seemingly that was the challenge ??

---

<div class="post-metadata">

**Author:** ![tasksolver](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/tasksolver/32/1067_2.png) [@tasksolver](https://talk.openelis-global.org/u/tasksolver)\
**Post date:** [November 13, 2024, 9:37pm UTC](https://talk.openelis-global.org/t/error-not-authenticated/241/20 "2024-11-13T21:37:43Z")

</div>

hello @aditya , I realized something strange just of recent.  
I have been facing this issue of “Not Authenticated” then using this solution at first worked till like 4 days ago when I got the same challenge regardless re-running the solutions provided. I am stuck

[Next page](https://talk.openelis-global.org/t/error-not-authenticated/241.md?page=2)
