# Help on install OpenELIS on ubuntu 22.04

**URL:** https://talk.openelis-global.org/t/help-on-install-openelis-on-ubuntu-22-04/363
**Category:** Uncategorized
**Tags:** dev\_setup
**Created:** [February 24, 2024, 9:58pm UTC](https://talk.openelis-global.org/t/help-on-install-openelis-on-ubuntu-22-04/363 "2024-02-24T21:58:33Z")
**Posts on this page:** 7
**Page:** 1

<div class="post-metadata">

### Author: ![Sayed\_Abdo](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/sayed_abdo/32/178_2.png) [@Sayed\_Abdo](https://talk.openelis-global.org/u/Sayed_Abdo)
#### Post date: [February 24, 2024, 9:58pm UTC](https://talk.openelis-global.org/t/help-on-install-openelis-on-ubuntu-22-04/363/1 "2024-02-24T21:58:33Z")

</div>

I’m currently attempting to install OpenElis on my local machine, which is running Ubuntu 22.04 LTS. However, I have encountered a few questions along the way:

1. I initially installed Java 17 on my machine. Should I remove it and install Java 11 instead for compatibility with OpenElis?
2. When following the Dev Environment Setup Instructions, I encountered difficulty with the step regarding configuring Tomcat to support SSL. Specifically, I’m unsure how to proceed with the instruction to ‘Expand the server that runs OE’, as well as the subsequent steps.

Could anyone point me towards a tutorial or offer assistance with these issues? Your help would be greatly appreciated. Thank you. @Moses_Mutesasira

---

<div class="post-metadata">

### Author: ![aditya](https://avatars.discourse-cdn.com/v4/letter/a/df705f/32.png) [@aditya](https://talk.openelis-global.org/u/aditya)
#### Post date: [February 24, 2024, 10:23pm UTC](https://talk.openelis-global.org/t/help-on-install-openelis-on-ubuntu-22-04/363/2 "2024-02-24T22:23:25Z")

</div>

Hey @Sayed_Abdo welcome to openELIS 🙂

1. you can install java 11 and set it as default java version [no need to uninstall java 17]

2. can u provide logs/errors screenshot of the issue u are currently seen

---

<div class="post-metadata">

### Author: ![Sayed\_Abdo](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/sayed_abdo/32/178_2.png) [@Sayed\_Abdo](https://talk.openelis-global.org/u/Sayed_Abdo)
#### Post date: [February 26, 2024, 6:08am UTC](https://talk.openelis-global.org/t/help-on-install-openelis-on-ubuntu-22-04/363/3 "2024-02-26T06:08:23Z")

</div>

Thanks for you.  
I have a problem can you help me?  
I remove the project and make reinstall, and now when I write this command `docker-compose up -d --build`  
I get this

 ![image](https://canada1.discourse-cdn.com/flex030/uploads/openelisci/original/1X/962b2e40048a61935192b448ef32e549b8cb2047.png)

---

<div class="post-metadata">

### Author: ![Agaba\_Derrick\_Junior](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/agaba_derrick_junior/32/503_2.png) [@Agaba\_Derrick\_Junior](https://talk.openelis-global.org/u/Agaba_Derrick_Junior)
#### Post date: [February 26, 2024, 7:05am UTC](https://talk.openelis-global.org/t/help-on-install-openelis-on-ubuntu-22-04/363/4 "2024-02-26T07:05:23Z")

</div>

hey @Sayed_Abdo make sure you pull the latest image changes before spinning up the containers

> `docker-compose -f dev.docker-compose.yml pull oe.openelis.org frontend.openelis.org`

I’m also so inquisitive to know whathappens when you run

> docker-compose up – build

without the

> -d flag

otherwise I find this helpful

> [@Error "Not Authenticated"](https://talk.openelis-global.org/t/error-not-authenticated/241/4):
>
> can you try Pulling the latest image changes and spin up again ?? Pull the latest Image changes docker-compose -f dev.docker-compose.yml pull oe.openelis.org frontend.openelis.org Remove the containers docker-compose -f dev.docker-compose.yml down Start them again docker-compose -f dev.docker-compose.yml up -d

---

<div class="post-metadata">

### Author: ![Sayed\_Abdo](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/sayed_abdo/32/178_2.png) [@Sayed\_Abdo](https://talk.openelis-global.org/u/Sayed_Abdo)
#### Post date: [February 26, 2024, 9:55am UTC](https://talk.openelis-global.org/t/help-on-install-openelis-on-ubuntu-22-04/363/5 "2024-02-26T09:55:52Z")

</div>

I pull the latest images then I run  
`docker-compose up – build`  
and I get ERROR: No such service: –  
I think you mean to run `docker-compose up --build`,  
Generally I run `docker-compose up --build` and get this

 ![image](https://canada1.discourse-cdn.com/flex030/uploads/openelisci/original/1X/69108e3f780344b188f3bec64a0d1e240c897662.png)

and I remove the container and get this

 ![image](https://canada1.discourse-cdn.com/flex030/uploads/openelisci/original/1X/3ed389503415d79c6d6e6628961130aca3003174.png)

---

<div class="post-metadata">

### Author: ![Sayed\_Abdo](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/sayed_abdo/32/178_2.png) [@Sayed\_Abdo](https://talk.openelis-global.org/u/Sayed_Abdo)
#### Post date: [February 26, 2024, 11:22am UTC](https://talk.openelis-global.org/t/help-on-install-openelis-on-ubuntu-22-04/363/6 "2024-02-26T11:22:54Z")

</div>

I’ve managed to solve the problem! Thank you for your assistance.

I search for this  
ERROR: for proxy Cannot start service proxy: driver failed programming external connectivity on endpoint openelisglobal-proxy (202445d8a0a4d7b2a295de997b09e2047881f036c5a1a1c5b75034f82761ddf6): Error starting userland proxy: listen tcp4 0.0.0.0:80: bind: address already in use

and I run this command `sudo lsof -i :80` and I find that Apache web server is running and listening on port 80.  
so I run this command `sudo service apache2 stop` and when I run  
`docker-compose up -d --build`  
It’s work!

Thanks again for your help

---

<div class="post-metadata">

### Author: ![Moses\_Mutesasira](https://yyz2.discourse-cdn.com/flex030/user_avatar/talk.openelis-global.org/moses_mutesasira/32/72_2.png) [@Moses\_Mutesasira](https://talk.openelis-global.org/u/Moses_Mutesasira)
#### Post date: [February 26, 2024, 11:41am UTC](https://talk.openelis-global.org/t/help-on-install-openelis-on-ubuntu-22-04/363/7 "2024-02-26T11:41:42Z")

</div>

For Developement , you would want to use the [dev.docker-compose.yml](https://github.com/I-TECH-UW/OpenELIS-Global-2/blob/develop_3x/dev.docker-compose.yml) for Hot reloading your local changes.

see full [instructions](https://github.com/I-TECH-UW/OpenELIS-Global-2?tab=readme-ov-file#running-docker-compose-with-locally-compiledbuilt-artifacts-ie-the-war-file-and-react-code-for-developers)
