Development in Eclipse

I have tried unsuccessfully to set up my development environment. I have eclipse 2023-03 and tomcat v9. Every attempt has left with me 404 error:

**Type** Status Report
**Message** The requested resource [/OpenELIS-Global-2] is not available
**Description** The origin server did not find a current representation for the target resource or is not willing to disclose that one exists.

Not sure what I am doing wrong. Iam using the steps available here Dev Environment Setup Instructions - OpenELIS Global Documentation

Running oe from docker runs fine.

Hi @sthaiya,

I am confirming that the steps in the documentation are up to date. In the meantime, I have a few questions that will help me ascertain why this is happening for you:

  1. Click on the OpenELIS-Global-2 project that should be in the leftmost pane under the Project Explorer tab. While the project is highlighted, navigate to Project on the top menu bar, and ensure Build Automatically is checked off. Once again navigate to Project on the top menu bar and click Clean... in the dropdown. Ensure Clean all projects is checked and click Clean. At the bottom right of Eclipse there should be a message that briefly says Cleaning all projects... followed by Building. Do those messages appear for you?

  2. When you start the tomcat server in Eclipse, do you see anything in the Eclipse console tab that indicates that it is detecting the project? for example Initializing Spring root WebApplicationContext or Initializing Spring DispatcherServlet 'dispatcher'.

  3. Does the console tab display any error messages? They should be in the format of 28 Mar. 2023 18:00:24 -- ERROR -- Context initialization failed , but the message is likely different

I have done steps1 and it completes successfully displayig the messages. Step 2 also passes but throws error in accessing hapi fhir.
Caused by: Failed to parse response from server when performing GET to URL - org.apache.http.conn.HttpHostConnectException: Connect to [] failed: Connection refused

The docker container for fhir is running.
Here is the full log Pastie


Thank you for the additional information. I believe I know what is causing the issue. The address uses the docker service name to find the co-resident FHIR server. When running OpenELIS-Global outside of the docker network, it can no longer reach it at that address.

The most effective solution that will allow you to change between eclipse development and docker development is to add a local DNS entry that maps to In Ubuntu, this is done by adding an entry in the /etc/hosts file like

Another issue that may affect you is that the co-resident FHIR server we use changed the path from /hapi-fhir-jpaserver/fhir/ to /fhir/, but if it was working in docker, then I suspect you may not need to change that address.

Let me know if the above works for you.

Thanks alot @calebslane.

This fixed it. changed path to /fhir/ and mapped my docker based fhir server in my hosts file.
Really appreciated.

I haven’t started on the installations yet but why is Eclipse the only one of all IDEs chosen for this purpose?
Are IntelliJ and VS Code problematic in setting up OPENELIS?
I am asking for clarity

I personally use VS Code .
Any IDE can work. The only challenge would be installing a Jasper reports pluggin for other IDEs.
I haven’t found any other Jasper reports plugins for other IDEs apart from eclipse.

So you can use VS-Code for all other developments apart from creating reports

1 Like