Help on install OpenELIS on ubuntu 22.04

I’m currently attempting to install OpenElis on my local machine, which is running Ubuntu 22.04 LTS. However, I have encountered a few questions along the way:

  1. I initially installed Java 17 on my machine. Should I remove it and install Java 11 instead for compatibility with OpenElis?
  2. When following the Dev Environment Setup Instructions, I encountered difficulty with the step regarding configuring Tomcat to support SSL. Specifically, I’m unsure how to proceed with the instruction to ‘Expand the server that runs OE’, as well as the subsequent steps.

Could anyone point me towards a tutorial or offer assistance with these issues? Your help would be greatly appreciated. Thank you. @Moses_Mutesasira

Hey @Sayed_Abdo welcome to openELIS :slightly_smiling_face:

  1. you can install java 11 and set it as default java version [ no need to uninstall java 17 ]

  2. can u provide logs/errors screenshot of the issue u are currently seen

Thanks for you.
I have a problem can you help me?
I remove the project and make reinstall, and now when I write this command docker-compose up -d --build
I get this

hey @Sayed_Abdo make sure you pull the latest image changes before spinning up the containers

docker-compose -f dev.docker-compose.yml pull

I’m also so inquisitive to know whathappens when you run

docker-compose up – build

without the

-d flag

otherwise I find this helpful

1 Like

I pull the latest images then I run
docker-compose up – build
and I get ERROR: No such service: –
I think you mean to run docker-compose up --build,
Generally I run docker-compose up --build and get this

and I remove the container and get this

I’ve managed to solve the problem! Thank you for your assistance.

I search for this
ERROR: for proxy Cannot start service proxy: driver failed programming external connectivity on endpoint openelisglobal-proxy (202445d8a0a4d7b2a295de997b09e2047881f036c5a1a1c5b75034f82761ddf6): Error starting userland proxy: listen tcp4 bind: address already in use

and I run this command sudo lsof -i :80 and I find that Apache web server is running and listening on port 80.
so I run this command sudo service apache2 stop and when I run
docker-compose up -d --build
It’s work!

Thanks again for your help

For Developement , you would want to use the dev.docker-compose.yml for Hot reloading your local changes.

see full instructions