Running OpenELIS directly with Docker docker Compose

You can Run OpenELIS directly with docker-compose without first downloading the installer.


Thanks, going to give this a spin and revert

1 Like

Hi @Moses_Mutesasira , I have tried following the steps and successfully cloned the project.
However, on running the docker-compose up -d or the docker-compose -f docker-compose-2x.yml up -d commands I ran into the same error
Error response from daemon: Head “”: denied: denied

How can I go about this?

@thembo42 , did you succeed running OpenELIS with Docker-compose ??
did you run into any such issue ??

sure, I did set up successfully, the only change was to upgrade my java version.
I did not see such an issue.

1 Like

@basrem , i dont think ive ever ran into that issue . I’ve ran the docker-setup on multiple servers and it works fine .
A quick Google search landed me on this StackOverflow thread

1 Like

Thanks, will revert with progress

@basrem , I updated our CI to push images to Docker Hub instead of the GitHub Container Registry.
I updated the docker-compose setup to pull images from Docker hub .

If you pull the latest changes I made, it should solve your problem

Thanks, @Moses_Mutesasira been able to start the 3.X version of OE

I am curious, how come the previous solution didn’t work, if you don’t mind, it is helpful for me in my learning curve. Thanks again!

hello @basrem
I can’t really give a concrete reason but in general, there are sometimes authentication issues with the GitHub container registry .
So I just switched to Docker hub .

Hey @Moses_Mutesasira. I tried following the above steps using Gitpod, but the ports all show different errors, is there a specific guide for such an avenue of setup

can you be specific about which port you’re trying to access and the error ??
And also , to avoid proxy related issues , access the app through the ports routed to your localhost