Mvn clean install -DskipTests command failure

Hey community, I have followed the instructions in the project documentation meticulously, including initializing and building sub modules, and ensuring that the Maven and Java versions align with the project requirements. However, I am encountering a persistent issue during the build process, specifically related to the maven-compiler-plugin and the use of the --release flag.
any idea on how to go about this will be helpful !!
@Moses_Mutesasira @caseyi @thembo42

@Agaba_Derrick_Junior be sure you have pulled latest changes and checkout the right branch then build again the sub modules.

Do you have any local changes in the checked out branch? If not, run the following:

git reset --hard git clean -df mvn clean install

what does mvn -v return on your machine ??
Am mostly interested in what java version your JAVA_HOME points to , because the error could be related to incompatible java versions


This is the output i get when i run the above command

hey @thembo42 i have been running this git reset --hard git clean -df mvn clean install and still facing the same issue

OpenELIS is setup to be compiled with Java 11 .

Can you install java 11 and have your JAVA_HOME point to that ??

i solved this by upgrading from maven 3.6.9 to 3.9.6, i also upgraded from java 8 to 11