Invalid Login Credentials

I’m hitting https://localhost:8443/OpenELIS-Global/LoginPage on my localhost. and trying to login with the credentials given on github (user:password = admin:adminADMIN!).
I have rebuilt the war file, restarted the dev-docker-compose container but couldn’t login.

Same credentials work on demo site, but does not work on my local host.

Any guidance will be appreciated.

Hey @Prajjwal_Kohli welcome to openELIS :slightly_smiling_face:

The default URL should be https://localhost/api/OpenELIS-Global/ don’t put any port . Because redirecting will be performed also port mapping already performed in the project. You don’t need to provide any default port by yourself.

No improvement even after using this url.
Are you able to do sign in @aditya?
Thanks btw.

I tried https://localhost/login and now I’m getting somewhat different login page.
Still the invalid credentials issue persists.

@Moses_Mutesasira can you help in this issue.

Can you make sure you don’t have any trailing spaces?

@Moses_Mutesasira Checked it there are no trailing spaces.

Things that I have tried:

  • pulling docker files for open-elis frontend

  • putting the containers down

  • restarting the containers

Here are my Logs for 1) backend 2) frontend

The backend and frontend seems to build fine without any errors.

Do you just copy and paste the credentials or you just type ??

I type manually. These same credentials works on the demo server, but not in my local host.

Try logging in here

The credentials work here


docker-compose -f dev.docker-compose.yml down -v    
docker system prune --volume
docker-compose -f dev.docker-compose.yml up -d  --no-deps --force-recreate    

After following the steps the site could’nt be reached, so i re-ran the first two commands and after executing the second command i ran

docker-compose -f dev.docker-compose.yml up -d
mvn clean install -DskipTests
docker-compose -f dev.docker-compose.yml up -d  --no-deps --force-recreate

By doing this the site was active but the credential issue was still there

I deleted and re-cloned the repo and the issue still persists.

I also noticed my git branch is origin/develop_3x is that the right branch or should i switch to origin/2.8, if this may be the source of the issue.

Hey @Prajjwal_Kohli try deleting the volumes images and containers of docker and re run ```
docker-compose command
it might work specially if there are conflicts or corruption while building existing volumes or images. Do let me know if it works!

In your case does this command returns anything in the terminal?

git submodule update --init --recursive

@Moses_Mutesasira I’m still not able to login.

What I’ve tried:

  • Updating docker
  • Updating Git
  • Deleting and Recloning the repo

Some details about my setup:

  • I have cloned develop_3x branch

  • I’m following Running docker compose With locally compiled/built Artifacts (ie the War file and React code) For Developers method to run the application

  • git submodule update --init --recursive does’nt return anything

I think will discuss your issue on the dev call DevDiscussion Break Happening Weekly every Thursday at 17:00-17:30 GMT - #43 by Agaba_Derrick_Junior

1 Like

Hey @Prajjwal_Kohli , I tried recreating the containers, and yeah, I faced the same issue of login credentials showing as invalid. I don’t know what the issue is!

Through trial and error, what I have done is killed the containers once again, then used docker-compose up, and after that, I used docker-compose -f dev.docker-compose.yml up -d, and it worked. I don’t know how, but it worked! Do check if it works for you too! and if it doesnt then dev discussion call is up for it!


Can anyone help me why it is showing not authenticated at https://localhost:3000/

How are you running the app ??
it should be accessed at https://localhost