Error "Not Authenticated"


Hey everyone, I’ve been experiencing an issue after fetching the latest changes on branch 2.8. Every time I fire up the server, I encounter a white screen with a message saying ‘not authenticated.’ Has anyone else encountered this problem, and if so, could you share any insights or solutions you’ve found?
@tendomart
@Moses_Mutesasira

I experienced this too some time back.

you proably need to clean your browser cache, docker cache and drop some dangling images.

@Moses_Mutesasira some thing needs to be done

1 Like

It may not be a priority, but i think we need to have a OpenELIS SDK to ease the process, setup on smaller footprint especially the frontend. Since we already have fhir endpoints, the UI can always use them separately.

1 Like

can you try
Pulling the latest image changes and spin up again ??

  • Pull the latest Image changes
    docker-compose -f dev.docker-compose.yml pull oe.openelis.org frontend.openelis.org

  • Remove the containers
    docker-compose -f dev.docker-compose.yml down

  • Start them again
    docker-compose -f dev.docker-compose.yml up -d

1 Like

Hey

context : [ I have dev.docker-compose.yml running in the background also i don’t have build errors ]

I have pulled latest images still having error [ Not Authenticated ]
also
I think there is no container which is handling request at localhost:3000/api/open…

still in trouble !

EDIT : problem solved : )

@aditya kindly share steps of how you have solved this

@Agaba_Derrick_Junior

when running npm run start on the frontend folder it sends you to https://localhost:3000 because of proxy already setuped on that port it doesn’t send api call/request to backend. To fix the problem just remove :3000 from the URL and write there /login.

the final url https:/localhost/login

That solved this issue/problem !

1 Like

We are running both the frontend and backend behind a proxy .
Just access the app on https:/localhost

Hello @Agaba_Derrick_Junior ,
Is there any progress on fixing your error from the dev call??

hey @Moses_Mutesasira sorry for the late replies, I am quite sick and am in the hospital,
I managed to fire up the server after the dev call but after a day or 2 of pulling the latest images, it’s now that I’m facing the same problem again

Sorry about that.
Quick recovery

hey @Moses_Mutesasira @caseyi

while running frontend from the src/frontend/ via command npm run start !
i got the above image error i think that is causing because non of the containers is handling that route [ https://localhost:3000/api/OpenELIS-Global/ValidateLogin?apiCall=true ]

i have that error i want to run the backend using containers and frontend from local command. Also and don’t want to start frontend from containers mean while it should be constant connection .

Please help :cry:

Thank You

@Moses_Mutesasira sorry for tag !
please help me with above issue and tell the steps required to perform !

Both the front end and backend are running behind the nginix poxy.
so the actual URL is https://localhost

Is there a technical reason you don’t want to run it in the containers ?? ideally, it still hot reloads from the container.

But if you want to run the frontend on your machine , then you’ll have to adjust the nginx configuration appropriately depending on your OS

hello community,
am facing this problem which is again bringing a not Authenticated error,

@mozzymutesa

Hey @Agaba_Derrick_Junior try killing and recreating the containers!

 docker-compose -f dev.docker-compose.yml down -v

Then

 cd OpenELIS-Global-2
 git submodule update --init --recursive
 cd dataexport
 mvn clean install -DskipTests

after this

 docker-compose -f dev.docker-compose.yml up -d    

if this doesn’t fix perform 1 & 2 nd step again and this time

run

docker-compose -f dev.docker-compose.yml up -d  --no-deps --force-recreate oe.openelis.org          

and then run

 docker-compose -f dev.docker-compose.yml up -d    
2 Likes

surely this worked ! thanks @aditya @Manish

3 Likes