Unable to run codebase locally with docker

After running commands in the READme section of the openElis Global 2 github, when I get to the command " docker-compose -f dev.docker-compose.yml up -d", I get the errors below. Please, what do I need to do.

Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/urllib3/connectionpool.py”, line 700, in urlopen
httplib_response = self._make_request(
File “/usr/lib/python3/dist-packages/urllib3/connectionpool.py”, line 395, in _make_request
conn.request(method, url, **httplib_request_kw)
File “/usr/lib/python3.10/http/client.py”, line 1283, in request
self._send_request(method, url, body, headers, encode_chunked)
File “/usr/lib/python3.10/http/client.py”, line 1329, in _send_request
self.endheaders(body, encode_chunked=encode_chunked)
File “/usr/lib/python3.10/http/client.py”, line 1278, in endheaders
self._send_output(message_body, encode_chunked=encode_chunked)
File “/usr/lib/python3.10/http/client.py”, line 1038, in _send_output
File “/usr/lib/python3.10/http/client.py”, line 976, in send
File “/usr/lib/python3/dist-packages/docker/transport/unixconn.py”, line 30, in connect
PermissionError: [Errno 13] Permission denied

During handling of the above exception, another exception occurred:

Before I ran the command " docker-compose -f dev.docker-compose.yml up -d", I ran the following commands

Hey @Tochi I am not sure , but if its an permission issue try running with

sudo docker-compose -f dev.docker-compose.yml up -d
Also sometimes, restarting the Docker service can resolve connection issues.

And If the issue still persists, you can try following the steps outlined in this video: Troubleshooting Docker Connection Issues.
Let me know if it works for you!:blush:

Hi Manish, thanks for your help. So I get a new error when I run the command above. I get “ERROR: Get “https://registry-1.docker.io/v2/itechuw/openelis-global-2-frontend-dev/manifests/sha256:3341b39b76bdec9fcf1d9353f03db3193942ce1f6994b9c0d02d0385fe9f6b66”: read tcp> read: connection reset by peer”

Never mind @Manish, it works now. But, was the username and password changed?. I get a Notification that username or password is incorrect, when i use:

Username: admin
Password: adminADMIN!

Please see picture attached.

1 Like

Hey @Tochi i have faced this issue earlier ! You can resolve this following this thread.
I have explained over there how to resolve this issue!


Thanks for your response. So when i ran the command " sudo docker compose up", i go to login into the application. But when i ran the command “sudo docker compose up”, then I stopped the server and ran “sudo docker-compose -f dev.docker-compose.yml up -d”, the application did not load, it gave an error of “502 bad gateway”.

So I stuck with running the app with the command “sudo docker compose up”, since its what works, but when I make changes locally to the frontend, i dont see my changes reflecting in the browser. Is there a way around this?

Hey @Tochi i just meant that for the inital setup you go with docker compose up and then thereafter you can always go with
docker-compose -f dev.docker-compose.yml up -d and as for the bad gateway is concerned sometimes it takes time for the page to load and also to load the containers properly , you just have to wait for 1-2 min and for implementing changes in frontend you have to go with the command docker-compose -f dev.docker-compose.yml up -d only!

You can remove -d hifen incase you want to see the logs.